Improper Input Validation vulnerability in Apache Tomcat.
Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112.
Older, EOL versions are also affected.
Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Alma_linux | — | Upgrade tomcat-servlet-4.0-apiUpgrade tomcatUpgrade tomcat-webappsUpgrade tomcat-el-3.0-apiUpgrade tomcat-libUpgrade tomcat-docs-webappUpgrade tomcat-admin-webappsUpgrade tomcat-jsp-2.3-api | Oct 11, 2026 | Sep 17, 2026 |
| Amazon Linux Ami 2 | — | Upgrade tomcat-jsvcUpgrade tomcat-webappsUpgrade tomcat-jsp-2.2-apiUpgrade tomcat-jsp-2.3-apiUpgrade tomcat-servlet-4.0-apiUpgrade tomcat-admin-webappsUpgrade tomcat-el-3.0-apiUpgrade tomcat-libUpgrade tomcat-docs-webappUpgrade tomcat-javadocUpgrade tomcatUpgrade tomcat-el-2.2-apiUpgrade tomcat-servlet-3.0-api | May 20, 2026 | May 20, 2026 |
| Apache Tomcat | — | Upgrade Apache Tomcat to 10.1.50Upgrade Apache Tomcat to 9.0.113Upgrade Apache Tomcat to 11.0.15Upgrade Apache Tomcat to the latest available version | Feb 18, 2026 | Feb 17, 2026 |
| Debian | — | Upgrade tomcat9Upgrade tomcat11Upgrade tomcat10 | Feb 19, 2026 | Feb 19, 2026 |
| Redhat_linux | — | Upgrade tomcat9-admin-webappsUpgrade jws6-tomcat-jsp-3.1-apiUpgrade tomcat9-docs-webappUpgrade jws6-tomcat-servlet-6.0-apiUpgrade jws6-tomcatUpgrade tomcatUpgrade tomcat-servlet-4.0-apiUpgrade tomcat-jsp-2.3-apiUpgrade jws6-tomcat-libUpgrade tomcat-docs-webappUpgrade tomcat-el-3.0-apiUpgrade tomcat-webappsUpgrade jws6-tomcat-admin-webappsNo solution existsUpgrade jws6-tomcat-docs-webappUpgrade tomcat9-webappsUpgrade tomcat9-libUpgrade tomcat9-el-3.0-apiUpgrade tomcat9-servlet-4.0-apiUpgrade tomcat-libUpgrade jws6-tomcat-javadocUpgrade jws6-tomcat-el-5.0-apiUpgrade tomcat-admin-webappsUpgrade jws6-tomcat-webappsUpgrade tomcat9Upgrade jws6-tomcat-selinuxUpgrade tomcat9-jsp-2.3-api | May 4, 2026 | Feb 17, 2026 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub