Cross-site scripting (XSS) vulnerability in WebKit in Apple Safari before 4.0.2, as used on iPhone OS before 3.1, iPhone OS before 3.1.1 for iPod touch, and other platforms, allows remote attackers to inject arbitrary web script or HTML via vectors related to parent and top objects.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Apple Ios | — | Upgrade to the latest version of Apple iOS | Oct 8, 2014 | Jul 9, 2009 |
| Apple Safari | — | Uninstall Apple Safari on WindowsUpgrade to Apple Safari version 4.0.2 | Jan 5, 2012 | Jul 9, 2009 |
| Suse | — | Upgrade libwebkit-1_0-2Upgrade libwebkit-langUpgrade webkit-jscUpgrade libwebkit-develUpgrade libwebkit-1_0-2-32bit | Feb 17, 2015 | Jul 9, 2009 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub