The array_user_key_compare function in PHP 4.4.6 and earlier, and 5.x up to 5.2.1, makes erroneous calls to zval_dtor, which triggers memory corruption and allows local users to bypass safe_mode and execute arbitrary code via a certain unset operation after array_user_key_compare has been called.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Apple Osx Php | — | Apply OS X security update 2007-007 | Dec 16, 2011 | Mar 16, 2007 |
| Gentoo Linux | — | Upgrade dev-lang/php. | Oct 30, 2017 | Mar 16, 2007 |
| Php | — | Upgrade to PHP version 5.2.2 | Oct 1, 2012 | Mar 16, 2007 |
| Suse | — | Upgrade php4-pgsqlUpgrade php4-unixODBCUpgrade php5-xmlwriterUpgrade php5-gettextUpgrade apache2-mod_php5Upgrade php5-mbstringUpgrade php5-sysvsemUpgrade php4-mcryptUpgrade apache-mod_php4Upgrade php4-shmopUpgrade php5-wddxUpgrade php5-sysvshmUpgrade php4-ypUpgrade php5-tidyUpgrade php5-pearUpgrade php4-curlUpgrade mod_php4-coreUpgrade php5-socketsUpgrade php5-iconvUpgrade php5-posixUpgrade php4-ldapUpgrade php5-sysvmsgUpgrade php5-xslUpgrade php4-snmpUpgrade php5-xmlrpcUpgrade php4-imapUpgrade mod_php4-apache2Upgrade php4-readlineUpgrade php4-dbaseUpgrade php4-sysvsemUpgrade php5-bcmathUpgrade php4-mbstringUpgrade php5-imapUpgrade php4-pearUpgrade php4-bcmathUpgrade php4-ftpUpgrade php5-domUpgrade php5-zipUpgrade php5-ftpUpgrade php4-gettextUpgrade php5-ctypeUpgrade php4-recodeUpgrade php4-qtdomUpgrade php5-opensslUpgrade php4-gmpUpgrade php5-exifUpgrade php5-fastcgiUpgrade php4-bz2Upgrade php4-xsltUpgrade php5-xmlreaderUpgrade php4-exifUpgrade php5-snmpUpgrade php5-pgsqlUpgrade php5-shmopUpgrade php5-ldapUpgrade php4-develUpgrade php5-pspellUpgrade php5-dbaseUpgrade php4-zlibUpgrade mod_php4-servletUpgrade php4-socketsUpgrade php5-bz2Upgrade php5-hashUpgrade php4-ctypeUpgrade php5-dbaUpgrade php4-calendarUpgrade php5-mcryptUpgrade php4-fileproUpgrade php4-mime_magicUpgrade php4-gdUpgrade php5-odbcUpgrade php5-jsonUpgrade php4-dbaUpgrade suse-releaseUpgrade apache2-mod_php4Upgrade php5-develUpgrade php4-mysqlUpgrade php5-pcntlUpgrade php5-curlUpgrade php5-tokenizerUpgrade php5-ncursesUpgrade php5-gmpUpgrade php5-gdUpgrade php5-mhashUpgrade php4-mhashUpgrade php5-suhosinUpgrade php4-swfUpgrade php4-mcalUpgrade php4-wddxUpgrade php4-sysvshmUpgrade php4-fastcgiUpgrade php5-soapUpgrade php5-zlibUpgrade php4-domxmlUpgrade php5-sqliteUpgrade php4-sessionUpgrade php4-iconvUpgrade php5-pdoUpgrade php5-calendarUpgrade php5-mysql | Feb 17, 2015 | Mar 16, 2007 |
| Ubuntu | — | Upgrade php5-sqliteUpgrade php5-cgiUpgrade php5-cliUpgrade libapache2-mod-php5 | Nov 8, 2024 | Mar 16, 2007 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub