Multiple use-after-free vulnerabilities in WebKit, as used in Apple Safari before 4.1.3 and 5.0.x before 5.0.3, Google Chrome before 5.0.375.127, and webkitgtk before 1.2.6, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via vectors related to improper handling of MIME types by plug-ins.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Apple Safari | — | Upgrade to Apple Safari version 5.0.3Upgrade to Apple Safari version 4.1.3Uninstall Apple Safari on Windows | Jan 5, 2012 | Aug 24, 2010 |
| Freebsd | — | Upgrade webkit-gtk2 | Dec 10, 2025 | Oct 19, 2010 |
| Google Chrome | — | Upgrade to the latest version of Google Chrome | Aug 30, 2012 | Aug 24, 2010 |
| Oracle_linux | — | Upgrade webkitgtk-docUpgrade webkitgtk-develUpgrade webkitgtk | Oct 16, 2024 | Aug 24, 2010 |
| Suse | — | Upgrade libwebkit-1_0-2Upgrade libwebkit-1_0-2-32bitUpgrade libwebkit-langUpgrade webkit-jscUpgrade libwebkit-devel | Feb 17, 2015 | Aug 24, 2010 |
| Ubuntu | — | Upgrade chromium-browserUpgrade webkit | Nov 19, 2024 | Aug 24, 2010 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub