Rapid7 Vulnerability & Exploit Database

Atlassian Confluence: Local File Disclosure vulnerability (CVE-2019-3394)

Back to Search

Atlassian Confluence: Local File Disclosure vulnerability (CVE-2019-3394)

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:N)
Published
08/29/2019
Created
09/09/2019
Added
09/09/2019
Modified
09/09/2019

Description

There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under <install-directory>/confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sensitive information such as LDAP credentials. The LDAP credential will be potentially leaked only if the Confluence server is configured to use LDAP as user repository. All versions of Confluence Server from 6.1.0 before 6.6.16 (the fixed version for 6.6.x), from 6.7.0 before 6.13.7 (the fixed version for 6.13.x), and from 6.14.0 before 6.15.8 (the fixed version for 6.15.x) are affected by this vulnerability.

Solution(s)

  • atlassian-confluence-upgrade-6_13_7
  • atlassian-confluence-upgrade-6_15_8
  • atlassian-confluence-upgrade-6_6_16

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;