Rapid7 Vulnerability & Exploit Database

Cisco XE: CVE-2024-20265: Cisco Access Point Software Secure Boot Bypass Vulnerability

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Cisco XE: CVE-2024-20265: Cisco Access Point Software Secure Boot Bypass Vulnerability

Severity
6
CVSS
(AV:L/AC:L/Au:S/C:C/I:C/A:N)
Published
03/27/2024
Created
05/10/2024
Added
05/06/2024
Modified
05/13/2024

Description

A vulnerability in the boot process of Cisco Access Point (AP) Software could allow an unauthenticated, physical attacker to bypass the Cisco Secure Boot functionality and load a software image that has been tampered with on an affected device. This vulnerability exists because unnecessary commands are available during boot time at the physical console. An attacker could exploit this vulnerability by interrupting the boot process and executing specific commands to bypass the Cisco Secure Boot validation checks and load an image that has been tampered with. This image would have been previously downloaded onto the targeted device. A successful exploit could allow the attacker to load the image once. The Cisco Secure Boot functionality is not permanently compromised.

Solution(s)

  • cisco-xe-update-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;