The array_user_key_compare function in PHP 4.4.6 and earlier, and 5.x up to 5.2.1, makes erroneous calls to zval_dtor, which triggers memory corruption and allows local users to bypass safe_mode and execute arbitrary code via a certain unset operation after array_user_key_compare has been called.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Apple Osx Php | — | Apply OS X security update 2007-007 | Dec 16, 2011 | Mar 16, 2007 |
| Gentoo Linux | — | Upgrade dev-lang/php. | Oct 30, 2017 | Mar 16, 2007 |
| Php | — | Upgrade to PHP version 5.2.2 | Oct 1, 2012 | Mar 16, 2007 |
| Suse | — | Upgrade php5-ncursesUpgrade php5-sqliteUpgrade php5-dbaseUpgrade php4-gdUpgrade php5-soapUpgrade php4-fastcgiUpgrade php5-bz2Upgrade php5-pgsqlUpgrade php4-sessionUpgrade php4-swfUpgrade php5-suhosinUpgrade php5-mcryptUpgrade suse-releaseUpgrade php4-develUpgrade apache2-mod_php4Upgrade php5-develUpgrade php4-fileproUpgrade php4-mcalUpgrade php5-mysqlUpgrade php5-pcntlUpgrade php4-mysqlUpgrade php5-curlUpgrade php4-socketsUpgrade php5-hashUpgrade php5-ldapUpgrade php5-gmpUpgrade php4-iconvUpgrade php4-zlibUpgrade php5-pdoUpgrade php4-mime_magicUpgrade php4-domxmlUpgrade php4-mhashUpgrade php5-snmpUpgrade php5-odbcUpgrade php4-wddxUpgrade php4-ctypeUpgrade php4-sysvshmUpgrade php5-jsonUpgrade php5-dbaUpgrade mod_php4-servletUpgrade php4-dbaUpgrade php5-mhashUpgrade php5-tokenizerUpgrade php4-calendarUpgrade php5-gdUpgrade php5-pspellUpgrade php5-calendarUpgrade php5-shmopUpgrade php5-zlibUpgrade php5-bcmathUpgrade php4-exifUpgrade php4-xsltUpgrade php5-pearUpgrade php4-ldapUpgrade php5-gettextUpgrade php5-posixUpgrade php4-dbaseUpgrade php4-imapUpgrade php4-shmopUpgrade php4-mcryptUpgrade php4-recodeUpgrade php5-sysvshmUpgrade php5-domUpgrade php4-unixODBCUpgrade php4-curlUpgrade php5-xslUpgrade apache-mod_php4Upgrade php4-readlineUpgrade php5-fastcgiUpgrade mod_php4-coreUpgrade php5-wddxUpgrade php4-pearUpgrade php4-qtdomUpgrade php5-mbstringUpgrade php5-ftpUpgrade php5-exifUpgrade php4-sysvsemUpgrade php4-gmpUpgrade php5-iconvUpgrade php4-mbstringUpgrade php4-bcmathUpgrade php5-tidyUpgrade mod_php4-apache2Upgrade php4-snmpUpgrade php4-ypUpgrade php5-sysvsemUpgrade php4-gettextUpgrade php5-xmlwriterUpgrade php5-sysvmsgUpgrade apache2-mod_php5Upgrade php5-ctypeUpgrade php5-xmlrpcUpgrade php4-pgsqlUpgrade php5-socketsUpgrade php4-ftpUpgrade php5-zipUpgrade php5-opensslUpgrade php5-imapUpgrade php4-bz2Upgrade php5-xmlreader | Feb 17, 2015 | Mar 16, 2007 |
| Ubuntu | — | Upgrade php5-cliUpgrade libapache2-mod-php5Upgrade php5-cgiUpgrade php5-sqlite | Nov 8, 2024 | Mar 16, 2007 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub