The setlocale function in PHP before 5.2.4 allows context-dependent attackers to cause a denial of service (application crash) via a long string in the locale parameter. NOTE: this might not be a vulnerability in most web server environments that support multiple threads, unless this issue can be demonstrated for code execution.
CVSS Details
- CVSS 3.1 Base Score: 5.3
Covered by Rapid7
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Gentoo Linux | — | Upgrade dev-lang/php. | Oct 30, 2017 | Sep 10, 2007 |
| Php | — | Upgrade to PHP version 5.2.4 | Oct 1, 2012 | Sep 10, 2007 |
| Suse | — | Upgrade php5-iconvUpgrade php4-pearUpgrade mod_php4-servletUpgrade php5-pearUpgrade php5-bz2Upgrade php4-ypUpgrade php4-exifUpgrade php5-mhashUpgrade php5-exifUpgrade php4-sessionUpgrade php5-ncursesUpgrade php4-readlineUpgrade php4-snmpUpgrade php5-soapUpgrade php5-mysqlUpgrade php5-ftpUpgrade php4-develUpgrade php4-sysvshmUpgrade php5-sqliteUpgrade php4-zlibUpgrade php4-recodeUpgrade php4-ldapUpgrade php5-shmopUpgrade php5-domUpgrade php5-snmpUpgrade php5-tidyUpgrade php5-curlUpgrade php5-pdoUpgrade php5-mbstringUpgrade php5-ldapUpgrade php4-qtdomUpgrade php5-jsonUpgrade php4-xsltUpgrade php5-gmpUpgrade php5-tokenizerUpgrade php5-mcryptUpgrade php5-odbcUpgrade php4-fileproUpgrade php5-sysvsemUpgrade php5-fastcgiUpgrade php5-socketsUpgrade php5-xmlreaderUpgrade php5-dbaUpgrade php4-gdUpgrade php5-opensslUpgrade php4-swfUpgrade php5-xslUpgrade php5-sysvmsgUpgrade apache2-mod_php5Upgrade php4-mcalUpgrade php4-domxmlUpgrade php5-sysvshmUpgrade php5-suhosinUpgrade php5-gdUpgrade php5-xmlwriterUpgrade php5-pgsqlUpgrade mod_php4-apache2Upgrade php5-posixUpgrade php4-curlUpgrade php4-pgsqlUpgrade php4-mhashUpgrade php4-ftpUpgrade php4-sysvsemUpgrade php4-wddxUpgrade php4-shmopUpgrade mod_php4-coreUpgrade php4-mcryptUpgrade php5-gettextUpgrade suse-releaseUpgrade php4-mbstringUpgrade php5-zlibUpgrade php5-pcntlUpgrade php4-gettextUpgrade apache-mod_php4Upgrade php5-ctypeUpgrade php4-bz2Upgrade php4-mime_magicUpgrade php5-develUpgrade php5-bcmathUpgrade php4-ctypeUpgrade php4-calendarUpgrade php4-dbaUpgrade php5-dbaseUpgrade php5-calendarUpgrade php4-imapUpgrade php5-zipUpgrade php4-dbaseUpgrade php4-fastcgiUpgrade php4-gmpUpgrade php5-pspellUpgrade php5-wddxUpgrade php4-mysqlUpgrade php4-unixODBCUpgrade php5-hashUpgrade apache2-mod_php4Upgrade php5-xmlrpcUpgrade php4-socketsUpgrade php4-iconvUpgrade php5-imapUpgrade php4-bcmath | Feb 17, 2015 | Sep 10, 2007 |
Prioritize with Active Threat Intelligence
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub