Interpretation conflict in Drupal 4.7.x before 4.7.11 and 5.x before 5.6, when Internet Explorer 6 is used, allows remote attackers to conduct cross-site scripting (XSS) attacks via invalid UTF-8 byte sequences, which are not processed as UTF-8 by Drupal's HTML filtering, but are processed as UTF-8 by Internet Explorer, effectively removing characters from the document and defeating the HTML protection mechanism.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Drupal | — | Upgrade to Drupal version 4.7.11Upgrade to Drupal version 5.6 | Aug 2, 2017 | Jan 15, 2008 |
| Freebsd | — | Upgrade drupal4Upgrade drupal5 | Dec 10, 2025 | Jan 11, 2008 |
| Ubuntu | — | Upgrade drupal5Upgrade drupal | Nov 19, 2024 | Jan 15, 2008 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub