Cross-site scripting (XSS) vulnerability in WebKit in Apple Safari before 4.0, iPhone OS 1.0 through 2.2.1, and iPhone OS for iPod touch 1.1 through 2.2.1 allows remote attackers to inject arbitrary web script or HTML via vectors related to determining a security context through an approach that is not the "HTML 5 standard method."
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Apple Safari | — | Upgrade to Apple Safari version 4.0Uninstall Apple Safari on Windows | Jan 5, 2012 | Jun 10, 2009 |
| Suse | — | Upgrade webkit-jscUpgrade libwebkit-1_0-2Upgrade libwebkit-develUpgrade libwebkit-1_0-2-32bitUpgrade libwebkit-lang | Feb 17, 2015 | Jun 10, 2009 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub