Multiple buffer overflows in the LWRES dissector in Wireshark 0.9.15 through 1.0.10 and 1.2.0 through 1.2.5 allow remote attackers to cause a denial of service (crash) via a malformed packet, as demonstrated using a stack-based buffer overflow to the dissect_getaddrsbyname_request function.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Centos_linux | — | Upgrade wiresharkUpgrade wireshark-gnome | Dec 1, 2016 | Feb 3, 2010 |
| Debian | — | Upgrade wireshark | Jul 30, 2024 | Feb 3, 2010 |
| Freebsd | — | Upgrade wiresharkUpgrade wireshark-lite | Dec 10, 2025 | Feb 10, 2010 |
| Oracle_linux | — | Upgrade wiresharkUpgrade wireshark-gnome | Oct 16, 2024 | Feb 3, 2010 |
| Suse | — | Upgrade wireshark-develUpgrade wireshark | Feb 17, 2015 | Jun 28, 2013 |
| Wireshark | — | Upgrade to Wireshark version 1.2.6Upgrade to Wireshark version 1.0.11 | May 3, 2018 | Feb 3, 2010 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub