Off-by-one error in the dissect_6lowpan_iphc function in packet-6lowpan.c in Wireshark 1.4.0 through 1.4.3 on 32-bit platforms allows remote attackers to cause a denial of service (application crash) via a malformed 6LoWPAN IPv6 packet.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Debian | — | Upgrade wireshark | Jul 30, 2024 | Mar 3, 2011 |
| Gentoo Linux | — | Upgrade net-analyzer/wireshark. | Oct 30, 2017 | Mar 2, 2011 |
| Suse | — | Upgrade wiresharkUpgrade libwsutil17Upgrade libwsutil7Upgrade libwiretap6Upgrade libwiretap16Upgrade libwscodecs1Upgrade libwiretap15Upgrade libwireshark8Upgrade wireshark-develUpgrade libwireshark9Upgrade libwsutil16Upgrade libwsutil8Upgrade wireshark-gtkUpgrade libwiretap7Upgrade libwireshark19Upgrade libwireshark18Upgrade wireshark-ui-qt | Feb 17, 2015 | Jun 28, 2013 |
| Wireshark | — | Upgrade to Wireshark version 1.4.4 | May 3, 2018 | Mar 2, 2011 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub