The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.10.x before 1.10.9 does not properly validate padding values, which allows remote attackers to cause a denial of service (buffer underflow and application crash) via a crafted packet.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Debian | — | Upgrade wireshark | Jul 30, 2024 | Aug 1, 2014 |
| Gentoo Linux | — | Upgrade net-analyzer/wireshark. | Oct 30, 2017 | Aug 1, 2014 |
| Oracle Solaris | — | Upgrade diagnostic/wireshark/wireshark-common to version 1.10.9-0.175.2.2.0.3.0 on Solaris 11.2Upgrade diagnostic/wireshark/tshark to version 1.10.9-0.175.2.2.0.3.0 on Solaris 11.2Upgrade diagnostic/wireshark to version 1.10.9-0.175.2.2.0.3.0 on Solaris 11.2 | May 29, 2017 | Aug 1, 2014 |
| Redhat_linux | — | No solution exists | Jul 9, 2025 | Jun 17, 2014 |
| Suse | — | Upgrade wireshark-develUpgrade libwscodecs1Upgrade wireshark-gtkUpgrade wiresharkUpgrade wireshark-ui-qtUpgrade libwireshark9Upgrade libwiretap6Upgrade libwsutil8Upgrade libwireshark8Upgrade libwsutil7Upgrade libwiretap7 | Dec 18, 2015 | Aug 1, 2014 |
| Wireshark | — | Upgrade to Wireshark version 1.10.9 | Oct 4, 2017 | Aug 1, 2014 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub