The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Struts | — | Upgrade to Apache Struts version 2.3.34Upgrade to Apache Struts version 2.5.13 | Sep 20, 2017 | Sep 20, 2017 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub