libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Debian | — | Upgrade vips | Jul 30, 2024 | Sep 11, 2023 |
| Ubuntu | — | Upgrade python-vipscc (Ubuntu Pro)Upgrade libvips-tools (Ubuntu Pro)Upgrade libvips42 (Ubuntu Pro)Upgrade gir1.2-vips-8.0 (Ubuntu Pro) | Oct 19, 2023 | Sep 11, 2023 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub