Rapid7 VulnDB

Drupal: CVE-2019-10911: Drupal core - Moderately critical - Multiple Vulnerabilities - SA-CORE-2019-005

Back to Search

Drupal: CVE-2019-10911: Drupal core - Moderately critical - Multiple Vulnerabilities - SA-CORE-2019-005

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
04/18/2019
Created
04/22/2019
Added
04/18/2019
Modified
04/18/2019

Description

This security release fixes third-party dependencies included in or required by Drupal core. CVE-2019-10909: Escape validation messages in the PHP templating engine . From that advisory: Validation messages were not escaped when using the form theme of the PHP templating engine which, when validation messages may contain user input, could result in an XSS. CVE-2019-10910: Check service IDs are valid . From that advisory: Service IDs derived from unfiltered user input could result in the execution of any arbitrary code, resulting in possible remote code execution. CVE-2019-10911: Add a separator in the remember me cookie hash . From that advisory: This fixes situations where part of an expiry time in a cookie could be considered part of the username, or part of the username could be considered part of the expiry time. An attacker could modify the remember me cookie and authenticate as a different user. This attack is only possible if remember me functionality is enabled and the two users share a password hash or the password hashes (e.g. UserInterface::getPassword()) are null for all users (which is valid if passwords are checked by an external system, e.g. an SSO).

Solution(s)

  • drupal-upgrade-8_5_1
  • drupal-upgrade-8_6_1

References

  • drupal-upgrade-8_5_1
  • drupal-upgrade-8_6_1

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;