Rapid7 Vulnerability & Exploit Database

F5 Networks: K9110 (CVE-2008-2370): Apache Tomcat information disclosure vulnerability - CVE-2008-2370

Back to Search

F5 Networks: K9110 (CVE-2008-2370): Apache Tomcat information disclosure vulnerability - CVE-2008-2370

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
08/03/2008
Created
07/25/2018
Added
11/14/2016
Modified
02/16/2017

Description

Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when a RequestDispatcher is used, performs path normalization before removing the query string from the URI, which allows remote attackers to conduct directory traversal attacks and read arbitrary files via a .. (dot dot) in a request parameter.

Solution(s)

  • f5-big-ip-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;