Rapid7 Vulnerability & Exploit Database

FFmpeg: CVE-2018-13304: Reachable Assertion

Back to Search

FFmpeg: CVE-2018-13304: Reachable Assertion

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:P)
Published
07/05/2018
Created
07/25/2018
Added
07/19/2018
Modified
10/04/2019

Description

In libavcodec in FFmpeg 4.0.1, improper maintenance of the consistency between the context profile field and studio_profile in libavcodec may trigger an assertion failure while converting a crafted AVI file to MPEG4, leading to a denial of service, related to error_resilience.c, h263dec.c, and mpeg4videodec.c.

Solution(s)

  • ffmpeg-upgrade-4_0_2
  • ffmpeg-upgrade-4_1

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;