Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2005-1759: GNU shtool, ocaml-mysql: Insecure temporary file creation

Back to Search

Gentoo Linux: CVE-2005-1759: GNU shtool, ocaml-mysql: Insecure temporary file creation

Severity
1
CVSS
(AV:L/AC:H/Au:N/C:N/I:P/A:N)
Published
06/28/2005
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Race condition in shtool 2.0.1 and earlier allows local users to modify or create arbitrary files via a symlink attack on temporary files after they have been created, a different vulnerability than CVE-2005-1751.

Solution(s)

  • gentoo-linux-upgrade-dev-ml-ocaml-mysql
  • gentoo-linux-upgrade-dev-util-shtool

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;