Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2018-1122: procps: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2018-1122: procps: Multiple vulnerabilities

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
05/23/2018
Created
07/25/2018
Added
05/31/2018
Modified
02/28/2020

Description

procps-ng before version 3.3.15 is vulnerable to a local privilege escalation in top. If a user runs top with HOME unset in an attacker-controlled directory, the attacker could achieve privilege escalation by exploiting one of several vulnerabilities in the config_file() function.

Solution(s)

  • gentoo-linux-upgrade-sys-process-procps

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;