Rapid7 Vulnerability & Exploit Database

RHSA-2010:0895: systemtap security update

Back to Search

RHSA-2010:0895: systemtap security update

Severity
7
CVSS
(AV:L/AC:L/Au:N/C:C/I:C/A:C)
Published
12/07/2010
Created
07/25/2018
Added
12/07/2010
Modified
07/04/2017

Description

SystemTap is an instrumentation system for systems running the Linuxkernel, version 2.6. Developers can write scripts to collect data on theoperation of the system. staprun, the SystemTap runtime tool, is used formanaging SystemTap kernel modules (for example, loading them).It was discovered that staprun did not properly sanitize the environmentbefore executing the modprobe command to load an additional kernel module.A local, unprivileged user could use this flaw to escalate theirprivileges. (CVE-2010-4170)Note: On Red Hat Enterprise Linux 4, an attacker must be a member of thestapusr group to exploit this issue. Also note that, after installing thisupdate, users already in the stapdev group must be added to the stapusrgroup in order to be able to run the staprun tool.Red Hat would like to thank Tavis Ormandy for reporting this issue.SystemTap users should upgrade to these updated packages, which containa backported patch to correct this issue.

Solution(s)

  • redhat-upgrade-systemtap
  • redhat-upgrade-systemtap-runtime
  • redhat-upgrade-systemtap-testsuite

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;