Rapid7 Vulnerability & Exploit Database

RHSA-2011:1019: libvirt security, bug fix, and enhancement update

Back to Search

RHSA-2011:1019: libvirt security, bug fix, and enhancement update

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:P)
Published
08/10/2011
Created
07/25/2018
Added
08/10/2011
Modified
07/04/2017

Description

The libvirt library is a C API for managing and interacting with thevirtualization capabilities of Linux and other operating systems.An integer overflow flaw was found in libvirtd's RPC call handling. Anattacker able to establish read-only connections to libvirtd could triggerthis flaw by calling virDomainGetVcpus() with specially-crafted parameters,causing libvirtd to crash. (CVE-2011-2511)This update fixes the following bugs:This update also adds the following enhancements:All libvirt users should install this update which addresses thisvulnerability, fixes these bugs and adds these enhancements. Afterinstalling the updated packages, libvirtd must be restarted ("servicelibvirtd restart") for this update to take effect.

Solution(s)

  • redhat-upgrade-libvirt
  • redhat-upgrade-libvirt-devel
  • redhat-upgrade-libvirt-python

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;