Rapid7 Vulnerability & Exploit Database

PHP Vulnerability: CVE-2005-3390

Back to Search

PHP Vulnerability: CVE-2005-3390

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
11/01/2005
Created
07/25/2018
Added
10/01/2012
Modified
07/21/2021

Description

The RFC1867 file upload feature in PHP 4.x up to 4.4.0 and 5.x up to 5.0.5, when register_globals is enabled, allows remote attackers to modify the GLOBALS array and bypass security protections of PHP applications via a multipart/form-data POST request with a "GLOBALS" fileupload field.

Solution(s)

  • php-upgrade-4_4_1
  • php-upgrade-5_1_0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;