Vulnerability & Exploit Database

Back to search

PHP possible overflow inside memnstr

Severity CVSS Published Added Modified
6 (AV:N/AC:L/Au:N/C:N/I:P/A:P) August 15, 2008 September 16, 2010 May 30, 2016

Description

Buffer overflow in the memnstr function in PHP 4.4.x before 4.4.9 and PHP 5.6 through 5.2.6 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via the delimiter argument to the explode function. NOTE: the scope of this issue is limited since most applications would not use an attacker-controlled delimiter, but local attacks against safe_mode are feasible.

Scan For This Vulnerability

Use our top-rated tool to discover, prioritize, and remediate your vulnerabilities

 Free InsightVM Trial

References

Solution

php-upgrade-5_2_7

Related Vulnerabilities