Rapid7 Vulnerability & Exploit Database

Red Hat: CVE-2018-10873: Important: spice and spice-gtk security update (Multiple Advisories)

Back to Search

Red Hat: CVE-2018-10873: Important: spice and spice-gtk security update (Multiple Advisories)

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
08/17/2018
Created
03/19/2019
Added
09/24/2018
Modified
03/03/2021

Description

A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

Solution(s)

  • redhat-upgrade-spice-debuginfo
  • redhat-upgrade-spice-glib
  • redhat-upgrade-spice-glib-devel
  • redhat-upgrade-spice-gtk
  • redhat-upgrade-spice-gtk-debuginfo
  • redhat-upgrade-spice-gtk-devel
  • redhat-upgrade-spice-gtk-python
  • redhat-upgrade-spice-gtk-tools
  • redhat-upgrade-spice-gtk3
  • redhat-upgrade-spice-gtk3-devel
  • redhat-upgrade-spice-gtk3-vala
  • redhat-upgrade-spice-server
  • redhat-upgrade-spice-server-debuginfo
  • redhat-upgrade-spice-server-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;