Rapid7 Vulnerability & Exploit Database

Rocky Linux: CVE-2022-28733: Important: grub2, mokutil, shim, and shim-unsigned-x64 security update (RLSA-2022-5095)

Back to Search

Rocky Linux: CVE-2022-28733: Important: grub2, mokutil, shim, and shim-unsigned-x64 security update (RLSA-2022-5095)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
07/07/2022
Created
07/16/2022
Added
07/11/2022
Modified
07/11/2022

Description

A flaw was found in grub2 when handling IPv4 packets. This flaw allows an attacker to craft a malicious packet, triggering an integer underflow in grub code. Consequently, the memory allocation for handling the packet data may be smaller than the size needed. This issue causes an out-of-bands write during packet handling, compromising data integrity, confidentiality issues, a denial of service, and remote code execution.

Solution(s)

  • rocky-upgrade-grub2
  • rocky-upgrade-grub2-common
  • rocky-upgrade-grub2-debuginfo
  • rocky-upgrade-grub2-debugsource
  • rocky-upgrade-grub2-efi-aa64
  • rocky-upgrade-grub2-efi-aa64-cdboot
  • rocky-upgrade-grub2-efi-aa64-modules
  • rocky-upgrade-grub2-efi-ia32
  • rocky-upgrade-grub2-efi-ia32-cdboot
  • rocky-upgrade-grub2-efi-ia32-modules
  • rocky-upgrade-grub2-efi-x64
  • rocky-upgrade-grub2-efi-x64-cdboot
  • rocky-upgrade-grub2-efi-x64-modules
  • rocky-upgrade-grub2-pc
  • rocky-upgrade-grub2-pc-modules
  • rocky-upgrade-grub2-tools
  • rocky-upgrade-grub2-tools-debuginfo
  • rocky-upgrade-grub2-tools-efi
  • rocky-upgrade-grub2-tools-efi-debuginfo
  • rocky-upgrade-grub2-tools-extra
  • rocky-upgrade-grub2-tools-extra-debuginfo
  • rocky-upgrade-grub2-tools-minimal
  • rocky-upgrade-grub2-tools-minimal-debuginfo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;