Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2006-2362

Back to Search

SUSE Linux Security Vulnerability: CVE-2006-2362

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/15/2006
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Buffer overflow in getsym in tekhex.c in libbfd in Free Software Foundation GNU Binutils before 20060423, as used by GNU strings, allows context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a file with a crafted Tektronix Hex Format (TekHex) record in which the length character is not a valid hexadecimal character.

Solution(s)

  • suse-upgrade-binutils
  • suse-upgrade-binutils-32bit
  • suse-upgrade-binutils-64bit
  • suse-upgrade-binutils-x86

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;