Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2009-0698

Back to Search

SUSE Linux Security Vulnerability: CVE-2009-0698

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
02/23/2009
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Integer overflow in the 4xm demuxer (demuxers/demux_4xm.c) in xine-lib 1.1.16.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a 4X movie file with a large current_track value, a similar issue to CVE-2009-0385.

Solution(s)

  • suse-upgrade-libxine-devel
  • suse-upgrade-libxine1
  • suse-upgrade-libxine1-32bit
  • suse-upgrade-libxine1-gnome-vfs
  • suse-upgrade-libxine1-pulse
  • suse-upgrade-xine-devel
  • suse-upgrade-xine-extra
  • suse-upgrade-xine-lib
  • suse-upgrade-xine-lib-32bit
  • suse-upgrade-xine-lib-64bit
  • suse-upgrade-xine-lib-x86
  • suse-upgrade-xine-ui

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;