Rapid7 Vulnerability & Exploit Database

Telerik UI for ASP.NET AJAX: Insufficiently Protected Credentials (CVE-2017-9248)

Back to Search

Telerik UI for ASP.NET AJAX: Insufficiently Protected Credentials (CVE-2017-9248)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
07/03/2017
Created
02/15/2020
Added
02/10/2020
Modified
04/07/2022

Description

Telerik.Web.UI.dll in Progress Telerik UI for ASP.NET AJAX before R2 2017 SP1 and Sitefinity before 10.0.6412.0 does not properly protect Telerik.Web.UI.DialogParametersEncryptionKey or the MachineKey, which makes it easier for remote attackers to defeat cryptographic protection mechanisms, leading to a MachineKey leak, arbitrary file uploads or downloads, XSS, or ASP.NET ViewState compromise.

Solution(s)

  • telerik-ui-for-asp-net-ajax-upgrade-17_2_621

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;