Rapid7 Vulnerability & Exploit Database

Wordpress: CVE-2019-8943: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Back to Search

Wordpress: CVE-2019-8943: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:P/A:N)
Published
02/19/2019
Created
03/19/2019
Added
02/27/2019
Modified
11/12/2019

Description

WordPress through 5.0.3 allows Path Traversal in wp_crop_image(). An attacker (who has privileges to crop an image) can write the output image to an arbitrary directory via a filename containing two image extensions and ../ sequences, such as a filename ending with the .jpg?/../../file.jpg substring.

Solution(s)

  • misc-no-solution-exists

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;