Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2020-8625: Important: bind security update (ALSA-2021-0670)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

Alma Linux: CVE-2020-8625: Important: bind security update (ALSA-2021-0670)



BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features. In a configuration which uses BIND's default settings the vulnerable code path is not exposed, but a server can be rendered vulnerable by explicitly setting valid values for the tkey-gssapi-keytab or tkey-gssapi-credentialconfiguration options. Although the default configuration is not vulnerable, GSS-TSIG is frequently used in networks where BIND is integrated with Samba, as well as in mixed-server environments that combine BIND servers with Active Directory domain controllers. The most likely outcome of a successful exploitation of the vulnerability is a crash of the named process. However, remote code execution, while unproven, is theoretically possible. Affects: BIND 9.5.0 -> 9.11.27, 9.12.0 -> 9.16.11, and versions BIND 9.11.3-S1 -> 9.11.27-S1 and 9.16.8-S1 -> 9.16.11-S1 of BIND Supported Preview Edition. Also release versions 9.17.0 -> 9.17.1 of the BIND 9.17 development branch


  • alma-upgrade-bind
  • alma-upgrade-bind-chroot
  • alma-upgrade-bind-devel
  • alma-upgrade-bind-export-devel
  • alma-upgrade-bind-export-libs
  • alma-upgrade-bind-lite-devel
  • alma-upgrade-bind-pkcs11
  • alma-upgrade-bind-pkcs11-devel
  • alma-upgrade-bind-pkcs11-libs
  • alma-upgrade-bind-pkcs11-utils
  • alma-upgrade-bind-sdb
  • alma-upgrade-bind-sdb-chroot

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center