Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2022-4603: Improper Restriction of Operations within the Bounds of a Memory Buffer

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Alpine Linux: CVE-2022-4603: Improper Restriction of Operations within the Bounds of a Memory Buffer

Severity
4
CVSS
(AV:A/AC:H/Au:S/C:P/I:P/A:P)
Published
12/18/2022
Created
04/09/2024
Added
03/26/2024
Modified
04/09/2024

Description

A vulnerability classified as problematic has been found in ppp. Affected is the function dumpppp of the file pppdump/pppdump.c of the component pppdump. The manipulation of the argument spkt.buf/rpkt.buf leads to improper validation of array index. The real existence of this vulnerability is still doubted at the moment. The name of the patch is a75fb7b198eed50d769c80c36629f38346882cbf. It is recommended to apply a patch to fix this issue. VDB-216198 is the identifier assigned to this vulnerability. NOTE: pppdump is not used in normal process of setting up a PPP connection, is not installed setuid-root, and is not invoked automatically in any scenario.

Solution(s)

  • alpine-linux-upgrade-ppp

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;