Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2020-1931: Moderate: spamassassin security update (CESA-2020:4625)

Back to Search

Centos Linux: CVE-2020-1931: Moderate: spamassassin security update (CESA-2020:4625)

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
01/30/2020
Created
11/06/2020
Added
11/05/2020
Modified
03/03/2021

Description

A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious Configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. This issue is less stealthy and attempts to exploit the issue will throw warnings. Thanks to Damian Lukowski at credativ for reporting the issue ethically. With this bug unpatched, exploits can be injected in a number of scenarios though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places.

Solution(s)

  • centos-upgrade-spamassassin
  • centos-upgrade-spamassassin-debuginfo
  • centos-upgrade-spamassassin-debugsource

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;