Rapid7 Vulnerability & Exploit Database

Debian: CVE-2023-24607: qt6-base, qtbase-opensource-src, qtbase-opensource-src-gles -- security update

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

Debian: CVE-2023-24607: qt6-base, qtbase-opensource-src, qtbase-opensource-src-gles -- security update

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
04/15/2023
Created
05/02/2024
Added
05/02/2024
Modified
05/02/2024

Description

Qt before 6.4.3 allows a denial of service via a crafted string when the SQL ODBC driver plugin is used and the size of SQLTCHAR is 4. The affected versions are 5.x before 5.15.13, 6.x before 6.2.8, and 6.3.x before 6.4.3.

Solution(s)

  • debian-upgrade-qt6-base
  • debian-upgrade-qtbase-opensource-src
  • debian-upgrade-qtbase-opensource-src-gles

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;