Rapid7 Vulnerability & Exploit Database

FreeBSD: VID-CD97C7CA-F079-11EA-9C31-001B216D295B (CVE-2020-7466): Multi-link PPP protocol daemon MPD5 remotely exploitable crash

Back to Search

FreeBSD: VID-CD97C7CA-F079-11EA-9C31-001B216D295B (CVE-2020-7466): Multi-link PPP protocol daemon MPD5 remotely exploitable crash

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
09/04/2020
Created
09/10/2020
Added
09/08/2020
Modified
10/20/2020

Description

Details for this vulnerability have not been published by NIST at this point. Descriptions from software vendor advisories for this issue are provided below.

From VID-CD97C7CA-F079-11EA-9C31-001B216D295B:

Version 5.9 contains security fix for L2TP clients and servers.

Insufficient validation of incoming L2TP control packet

specially crafted by unauthenticated user might lead to unexpected

termination of the process. The problem affects mpd versions

since 4.0 that brought in initial support for L2TP.

Installations not using L2TP clients nor L2TP server configuration were not affected.

Solution(s)

  • freebsd-upgrade-package-mpd5

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;