Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2020-17521: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2020-17521: SUSE Linux Security Advisory

Severity
2
CVSS
(AV:L/AC:L/Au:N/C:P/I:N/A:N)
Published
12/07/2020
Created
01/05/2021
Added
01/02/2021
Modified
01/02/2021

Description

Apache Groovy provides extension methods to aid with creating temporary directories. Prior to this fix, Groovy's implementation of those extension methods was using a now superseded Java JDK method call that is potentially not secure on some operating systems in some contexts. Users not using the extension methods mentioned in the advisory are not affected, but may wish to read the advisory for further details. Versions Affected: 2.0 to 2.4.20, 2.5.0 to 2.5.13, 3.0.0 to 3.0.6, and 4.0.0-alpha-1. Fixed in versions 2.4.21, 2.5.14, 3.0.7, 4.0.0-alpha-2.

Solution(s)

  • suse-upgrade-groovy
  • suse-upgrade-groovy-ant
  • suse-upgrade-groovy-bsf
  • suse-upgrade-groovy-console
  • suse-upgrade-groovy-docgenerator
  • suse-upgrade-groovy-groovydoc
  • suse-upgrade-groovy-groovysh
  • suse-upgrade-groovy-jmx
  • suse-upgrade-groovy-json
  • suse-upgrade-groovy-jsr223
  • suse-upgrade-groovy-lib
  • suse-upgrade-groovy-nio
  • suse-upgrade-groovy-servlet
  • suse-upgrade-groovy-sql
  • suse-upgrade-groovy-swing
  • suse-upgrade-groovy-templates
  • suse-upgrade-groovy-test
  • suse-upgrade-groovy-testng
  • suse-upgrade-groovy-xml

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;