Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2008-2785

Back to Search

SUSE Linux Security Vulnerability: CVE-2008-2785

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
06/19/2008
Created
07/25/2018
Added
12/12/2013
Modified
07/04/2017

Description

Mozilla Firefox before 2.0.0.16 and 3.x before 3.0.1, Thunderbird before 2.0.0.16, and SeaMonkey before 1.1.11 use an incorrect integer data type as a CSS object reference counter in the CSSValue array (aka nsCSSValue:Array) data structure, which allows remote attackers to execute arbitrary code via a large number of references to a common CSS object, leading to a counter overflow and a free of in-use memory, aka ZDI-CAN-349.

Solution(s)

  • suse-upgrade-mozilla-xulrunner190
  • suse-upgrade-mozilla-xulrunner190-32bit
  • suse-upgrade-mozilla-xulrunner190-64bit
  • suse-upgrade-mozilla-xulrunner190-devel
  • suse-upgrade-mozilla-xulrunner190-gnomevfs
  • suse-upgrade-mozilla-xulrunner190-gnomevfs-32bit
  • suse-upgrade-mozilla-xulrunner190-gnomevfs-64bit
  • suse-upgrade-mozilla-xulrunner190-translations
  • suse-upgrade-mozilla-xulrunner190-translations-32bit
  • suse-upgrade-mozilla-xulrunner190-translations-64bit
  • suse-upgrade-mozillafirefox
  • suse-upgrade-mozillafirefox-translations
  • suse-upgrade-mozillathunderbird
  • suse-upgrade-mozillathunderbird-devel
  • suse-upgrade-mozillathunderbird-translations
  • suse-upgrade-seamonkey
  • suse-upgrade-seamonkey-dom-inspector
  • suse-upgrade-seamonkey-irc
  • suse-upgrade-seamonkey-mail
  • suse-upgrade-seamonkey-spellchecker
  • suse-upgrade-seamonkey-venkman
  • suse-upgrade-suse-release

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;